Wednesday, July 30, 2014

Surf Champ: score reels

Quick update:  One of the problems with this machine was that the 2nd player 1000s rollover was not advancing the 10000s reel, thus meaning that after 9990 the score would reset to zero on a 10 point hit.
I did a quick inspection (and golly gee whiz is this machine clean, it must have been totally redone at some point,) and cleaned the contacts with a flextstone file.

After that, the 10000s reel advanced properly when the 1000s rolled over past 9000 to 10k.  But suddenly, the game started getting stalled in the reset sequence, with the motor running continuously.
I had seen this problem before, no?  Back with Royal Flush!
So first thing I did was using a chopstick and test the "zero position" contacts in the player 2 score reel, since that was the one I had fiddled with.  I had surely just misaligned something, but that did not fix the situation.

I was still able to play a game:  With the score motor chugging, I manually advanced the player unit solenoid to continue the reset sequence.

So I tried a 3 player game:  The test would be to see if it was actually a player 2 issue.  Players 1 and 2 are controlled by the Z1 relay.  If 1 or 2 were having a problem with their zero switches, it'd be stuck on the Z1.
But all 3 players reset before the motor got stuck in its loop.

So I did a 4 player game, got score on all reels, then reset.  The game then reset perfectly.

What this insinuates for me is that perhaps some dirt got in to the zeros contacts of the player 4 switches, and that caused the snag.  After a few 4 player games, the problem did not return so the contaminant seems to have dislodged itself.

Sunday, July 27, 2014

Surf Champ: blowing the GI fuse: investigation!

It has been a long time since I've talked about my little Surf Champ.  It is still here, but has been out of commission.  Why?  I started with an easy problem.  Then quickly got stuck.
On my "list of things to do," a big one was noting that the final rollover wasn't being hit.  A quick inspection and the switch was obviously bent away, so no way it could register.  I bent it back to a proper gap, went back to playing, hit all of the rollovers and... ..  FIZZLE ... POP.  Lights go out.

The switch was bent away for a reason:  When all 5 rollovers are collected, the 10A illumination circuit blows.
Wait, what?

OK so underneath the playfield, right at the back, is a bank of relays of the various scoring game states.  There are 5 relays, one for each rollover.  And a 6th nestled in amongst them, called 6B.  When all 5 other relays are down, 6B goes down and lights the spinner and the left and right rollover lanes.
But 6B isn't a coil, it is a special coilless relay.  It has a single spring and a long metal bar that spans it and the 5 other relay coils.  It pushes on them with a bit of tension, and when all 5 relays are down, that bar can be pulled in as well.

First up though, I checked all of the wiring under the PF.  If this was only occurring when 6B was active, I inspected for shorts amongst the relays, shorts and loose wires under the playfield in the areas where 6B lights things up, etc.

one of the few lights activated by 6B

All of the components connected and activated by 6B seemed to be A-OK.

While I had the playfield up I came on a critical discovery:  6B was not blowing the circuit when the playfield was up!  Ooooo that's a big clue.
It could be fine up, but then once lowered, when almost down flat, it would blow again.

The first thing I intuited was that the spinner changes position as the angle gets lower, maybe something was up with that?  6B does light the spinner for 100 points.  The spinner and associated relay all seemed to check out, but I was able to also give them some loving adjustments.

Then I checked for any dangling or loose wires under the playfield that would shift as the playfield descended, but that checked out.
so with the playfield seemingly fine, I focused on the relay itself.

This is no small thing, as the stack of relays at the back of the game are a touch imposing and rather difficult to get deep in to.  I took the playfield out and laid it suspended between a table and a loveseat, and was able to open up the rack bank and inspect things more closely.

notice the slight leaf alignment on the left
Not really knowing if a slight mis-alignment or weak connection could cause a power transfer issue (I've been astounded by less obscure things before,) I loosened the leaf stack, straightened it out, and tightened it agian.  This did not fix the problem.

Next theory was that when vertical, the gravity gives the 6B spring extra bull to bring that bar down.  When the playfield is in it's normal horizontal position, there might not be enough pull, bringing it to a poor connection.  Maybe?  Nope.
I struck down that quick little theory by having the playfield up, but then unhinging the relay bank, thus the relays would be aligned in the same manner as if the playfield was normally down.  With the playfield up and the relays down, 6B didn't blow anything, thus effectively ruling out the relay bank.

I did some testing with the alignment of the playfield, figuring how far it has to go down before the circuit goes wonky.  I even took the playfield out and lowered it mostly flat, juts away from the back of the machine, and it seemed to work then.  (that turns out to have been a fluke, and acted as a red herring in my investigations)

What was left?  Well when the playfield slides in to place there was one odd thing near the back: a big black block stuck to the wall.  Turns out this is an isolation transformer.

oh hello there, mystery box.

The power cord goes in, and the main transformer is plugged in to this one.  Turns out they were required by Ontario Hydro, back in the day, to separate machines from the central ground.  This would ensure that if something shorted internally, and someone touched this and another game, they wouldn't get high voltage through them.
This also meant that they also sucked power continuously when plugged in, even if the game (and thus main transformer) aren't turned on.  And almost nobody operates EMs outside of personal collections, so totally unneccesary.
115 in, 115 out???   stupid transformer!
My brain gurgled up a theory that HEY, maybe this transformer had an electromagnetic field, and that the 6B bar, being 6 relays wide, might be blowing the circuit when the playfield is lowered down towards this!  This theory was quickly corrected and dismissed by people that Know What They Are Talking About, but my research revealed that this still had to go.

I had to wait a while to get help taking the head of Surf Champ off to get access.  I used to think I was Ok strong since I can help move furniture around the house, but I am not Pinball Strong.  I can't lift an awkward 4-player EM head solo.  Or at least not safely.

This has got to be one of the densest things I have ever lifted!

Extracting it was fairly easy, and I spliced the external heavy duty line cord in to the meh weak one inside the machine, going in to the transformer.  Spliced, soldered, and capped.
When I sell Surf Champ, I will be happy to report the dead weight of the isolation transformer is no longer involved in the move.

But let's not forget why I was there in the first place:  No, this didn't fix this issue.
On some advice to do so, I went back to the harness with renewed vigor.  Then, 5 minutes later, I found the issue.  The issue I had spent weeks hypothesizing and spinning my wheels on.  The issue that had taken me to repair and fix a bunch of other stuff on the machine in pursuit of MAYBE THIS IS IT???

This was it:

Look at the leftmost black wire.  The shielding has rubbed through against the light bracket.  Very very very hard to see, since it's dark gray coated by black, but that is what was doing it.

Wrapped it in electrical tape, problem solved.  Played some Surf Champ.  On to a new challenge!

Wednesday, July 23, 2014

Beat The Clock: cleaning the shooter rod


I took some time to clean the shooter rod assembly.  This game requires a precision skill shot, and the shooter rod was very sticky and hard to adjust to the right tension.
So I took it all out, cleaned up some rust and gunk and now it plays much nicer.

The strategy, it seems, is to get the ball up towards the 4th (D) rollover.  Then it will bounce around in the S-T-O-P drops.  Then let it drain, shoot it up again and use the right flipper to align the lights for best being collected.    If done properly you can quickly get to a double playfield with the timer stopped!

Beat The Clock udpate

After having fixed the bonus kickout hole switch last time, I decided to add some protection.  I took off the surrounding plastics and cut some custom plastic sheeting to go in front of it.  Any place where the ball goes airborne and smacks down, that will inevitably wear.

right flipper switches:  bottom switch can close while the top remains open.  I need to correct this.

The right flipper can be used to alternate which of the S-T-O-P lights are lit, and which top rollover lanes are lit.
You'll see that even when the first switch is closed and the flipper is active, the change-lane switch is still open.  I want them in sync so that any flip rotates the lanes, so I adjusted the gapping to make them sync up.
This way you can reliably rotate the lights with the flipper without having to inspect to see if the lights actually moved.

Top left "A" lane was not registering when the ball would go across it too quickly, so again, fixed the gapping there.
said rollover switch

Then the other day I go to play it, flip the switch on and expect the glorious "BEAT THE CLOCK" squwacking speech.  Except... it just beeped.  And had no credits any more.  And the high-score was all 5s.  What happened?
It looks like the memory got wiped!  Battery was still there, but ummm maybe best to replace it.  Not sure what else could have caused it than battery issues.  So we have one of those on order.
But the game wouldn't play past booting up.  I couldn't coin up at all.   Was something amiss?  Why no "BEAT THE CLOCK" on bootup?  DID SOMETHING GO HORRIBLY WRONG?

our keypad technology is lightyears ahead of yours!

The answer was: not really, but kind of.  When the memory blipped, things went back to the "Factory settings".  I quickly found that "factory settings" contains a bunch of nonsensical register data that was hampering things.
This game has a tiny black button inside the door to go in to test mode, and to get all the way in you have to make sure there are no aberrant switches closed.  It signals them with a beep and a switch number.
Once all cleared, you use a quirky little key-pad on a cable to interface with the test modes.
the offending board battery?

Long story short, I finally figured out the issue was that the "Maximum Credits" register (register #10) was set to 8000.  The value is supposed to be betwen 1 and 40, so altering allowed for proper coin-door operation, and also let the start button work on free play (set register 27 to 65 for that).
I had to set the full sound and speech options to 3 to get to the point where it would say the wonderful "BEAT THE CLOCK" on bootup.

come on... say it... "BEAT THE CLOCK!"

I checked a number of the other registers, and definitely wonky data, even in registers that can't be overwritten.  Games played?  20,000.   Coins insert?  400,000.  Times the high score was beaten?  9,200,000....
At least I found the one bit of wacky data that was actually messing up the game operation.
After other power-ons, I noticed it is not holding on to sound settings or free play settings, but it is not a total memory wipe as it is holding the credits count.
The max credits raised up to something like 8010, but I imagine the system is only looking at the right 2 digits.  So when it was 8000 maximum credits, the system read that as 0.

Remember the small detail that the game is LIVE, and you could easily run current through yourself while touching the game and anything else?
Yeah.  That.
Unplugged the game and found the cord didn't have a ground plug!  UGGGH.
So new properly grounded plug coming.
So when the owner comes the priorities will be:  Line cord, then battery.

while messy, at least the standups work pretty well.

all different springs, and oh hey, one is missing!

So yeah:  new drops are coming.  See above.  :)

I tried putting in LEDs under the playfield but they don't handle the flickering animations well.  And with these old-style 555 sockets, I want to smash my head on the wall.  They are the WORST for accessing.  Give me the rotating bases for the 555s, or go have to 44s.
I swapped LEDs in to the GI but some sockets are a bit flakey though and might need eventual replacement.  This got me some spare 555s.
While I was swapped the LEDs I got some deeper cleaning in, and as well put lexan washers on the sling plastics.  I had hoped to put lexan under each of the plastics, but the rest of the plastics are half fastened by screws in to wood, and so the posts would be higher up, which probably bodes even worse for the plastics then leaving them unprotected.

With a salvaged 555 incandescent bulbs in hand I went to work replacing bulbs under the playfield, but then found a bunch of lights still did not work.  I will have to check voltages later, and see if I need to replace the sockets.

Also got some screws for the pop bumpers.  The pop assemblies snap together, but for when the snaps inevitably break there are little marked holes for where to drill.  I then had to go BACK to the store and get a size zero squaure driver because I've never owned one before.  But at least now the pop bumpers are 100% secured.

A  problem that is creeping up in importance:  The end of ball switch.  At least I think it's that switch.  Some times the ball is live and suddenly the game registers the end of ball sequence.  This of course is extra terrible when you have zero seconds remaining.
But also some times when the ball drains you have to hit the flipper buts for the end of ball sequence to initiate, so it might NOT just be a switch issue.

look in to end-of-ball switch issues
diagnose why the S-T-O-P standups can trigger pop bumper or right sling solenoids
replace drop targets
find why shooter lane eject can trigger left standups or right drop target
loose light socket
outhole lane: sometimes doesn't register until flippers pressed, sometimes signals end of ball when ball in play
adjust S-T-O-P standups to be more sensitive
replace board battery

cleaned shooter rod assembly
fixed bonus collect hole so ball doesn't get stuck
fixed "A" rollover sensitivity
lexan washers on pops
LEDs for GI lighting
secured pop bumperr plastics
right flipper now properly rotating S-T-O-P and upper rollover lights
repalced most lights under the playfield
deep cleaning + waxing
all new rubbers

Wednesday, July 9, 2014

Introducing... Beat The Clock

Dust doesn't get much chance to settle around here.  Top Score is officially on loan at a friend's place, and will get sold some time in August or September.
It was one of my favourite EM games, but I got an offer I couldn't refuse:  to borrow a 1985 Beat The Clock.
Yes, my first Solid State machine!!!!  I couldn't say no.

This game has a dynamite layout, and pretty much every goodie you'd want from a game in the first half of the 80s.
(If you can keep it a secret, I think many of the later 80s solid state games aren't as fun.  With the advent of multiball and ramps, EVERY game tried to shoehorn those things in, often with a sacrifice to design and flow.)

This game has some really great basic features:    A 6-bank drop target bank that protects 5 standups.  A wacky reversed left outlane.  A bonus collect hole in the upper left.  A channel to the top, protected by a single drop on the right.  An upper flipper.  4 rollovers and collect hole at the top.  And  standups in the upper right which are actually a strategic addition to the game.

There was only 500 of these made, and a lot of people just aren't in to this game, which might be a head-scratcher on the playfield glances alone.  But it is a timed game, and what that means is essentially it is a 1-ball game, except you have a long Ball-Saver that can freeze and extend.
I think many people are turned off by this aspect, but it forces you to rethink how you normally play pinball.   Not only are you going for points, building bonus and collecting, but you are also strategizing your risky play against the clock, trying to find ways to stop it, build it, prevent it from starting again.
Personally, I think it adds a lot of depth to the gameplay and forces you to constantly tweak your strategy and respond quickly.

First thing to do with a new arrival?  Get cleaning with the Novus 2 and then 1, then wax all of the main areas up as best possible.

the results of my initial clean, displayed in rag-form...
Then I played a number of more games with a pen and paper by my side and started taking notes of everything that was going wrong and/or needs to be looked in to.
I also put down some custom low-tack plastic sheets in the areas with wear to make sure the game doesn't get any new damage while with me.
I replaced the bottom flipper rubbers, since they were getting stale, but will eventually get new rubbers for the entire game.

I was warned by the last player that the collect hole was occasionally having a hard time detecting a ball in it, and thus not rewarding bonus and kicking it out.  This severely hampers game play, as you have to lift up the machine, or take the glass off, to get things moving again.

This collect hole is a huge part of the game, and it needs to be 100$

The collect hole from beneath

I didn't really need to remove the kicker mech, as I later found out, but it did allow me to give the switch a good cleaning and adjusting.
I reassembled it and realize I could have adjust it around the solenoid and bracket, but hey, live and learn.
Oh, and:  PROBLEM SOLVED!  I made the tip of the switch more prevalent, and reduced the gapping on the other half of the switch.  It was also a bit crooked, so I tried to bend them to be more parallel to each other.

These are hard-to-fit standups, but if you can nail them all they stop the clock.  The right flipper also rotates which ones are lit.
In my tests I found that some of these standups, when hit hard, would trigger a pop bumper or the right slingshot.  Definitely need to look in to that.  (At least from a playfield standpoint, I don't touch boards)
Also, most of the snaps on the pop bumpers are busted, so not much to hold the plastics on top.  I found one screw, so will take that in to a hardware store and see if I can buy replacements and secure all pop bumper parts.

with this rag-tag- band of drops, how can we go wrong?
The drop bank needs a lot of love, but let's take another moment to appreciate how cool it is to have a bank of standups offset behind the drops for extra scoring features!
I might replace all of the drops, but my immediate area of concern is the standups in the rear.  I noticed that sometimes when the ball ejects in to the shooter lane, the clock has started and some points are on the board.  Even if just first plunge.
What is supposed to happen is that, like the gun fire at the start of a race, the clock starts when you go through the gates at the top after your skill shot.  That sometimes is the case, and I feel it is very important to the race aesthetic of this game.
About 50%+ of the time, the ball goes in to the shooter lane and you hear a noise and get points, and the clock also starts.  I matched that noise up with what happens when you hit a standup, so most likely eject solenoid firing is tripping a switch over on the other side of the playfield.

Plastic just before the left flipper
Notice how the clear plastic tapers in the same manner as the top of the left flipper?  That allows balls to just sit there.
Ideally, and this is how it is on the right flipper, you want that plastic to come up to and hug the flipper's curves, creating a seamless path for the ball to roll.
I will have to look in to replacing that, or having a custom one fabricated.  It will greatly improve the gameplay.

More stuff:

Grounding is an issue on this machine.  I noticed a familiar tingle when touching another machine and also the key in the coin door slot, or some of the trim.  This is not something I will be doing, but I imagine the owner of the game knows how to fix the issue.

Many lights are out in this game.  Poking under the playfield, everything is bracketed like the old #44 bulbs, but all 555s.  THAT IS WEIRD.   It is super difficult to access any of the bulbs, but I am determined to at least get all of the sockets lighting again.  The difficulty of access probably means I am too annoyed to install full LEDs.
The left pop bumper's light socket is loose and will need re-securing.  The right flipper doesn't rotate the lights reliably, and probably needs a switch adjusted
Outhole is sometimes not registering until you press flipper buttons. 

find screws to affix all pop bumper plastics
diagnose why the S-T-O-P standups can trigger pop bumper or right sling solenoids.
replace the drop targets
find why standups behind the drops can be trigger by shooter lane eject.
Get grounding fixed:  get tingle when touching another cabinet.
Loose light socket in left pop bumper
Right flipper not doing a great job rotating the lights, check switches.
outhole switch sometimes not registering until you press flipper buttons
Many lights out
Fix/replace/adjust plastic to the left of the left flipper.
All new rubbers.

fixed bonus collect hole switch so ball doesn't get stuck.
clean + wax


this generic action art is the legacy of old Atari game box design, no doubt.