Friday, November 6, 2015

Alien Poker: lots of work!

We are knocking things off the list on Alien Poker.
I had some help today, and the assistance was much appreciated in fixing a problem I only recently started focusing on:  The left sling (the only sling in this game) was on for some games, but off for others.  Most likely a cracked solder joint or loose connector somewhere.
We took the board out and reflowed solder around the connectors and the "special solenoids" chips, and that took care of the issue.
Also put in the replacement resistors, and now all the lights are on and wonderful.

BTW, you can get amazing schematics for System 6 machines at FirePower Pinball, in their Tech Support section.  All schematics can be readily downloaded.

New drop target decals added.
hullo handsomes

All of the rubbers have been changed. (well, still need a 2" one...)

The left pop bumper's light wasn't working.  Want to know why?
oh wait that not's quite proper.

Installed a new light socket behind the drop targets as one there had basically crumbled.

After all that, there seems to be some issue with some of the lights not lighting properly (like the shoot again coming on) so some more investigation might be required.

Corvette: done?

After tonnes of research, a thread on MAACA and a more concise thread on Pinside, the problem seems to have disappeared after reinstalling the opto board.
So unsatisfying, but I guess I'll take it?  Might just be an intermittent issue, but I can't recreate the switch matrix issue any more.  Onward and upwards?
The opto board!  I tested all three chips for shorts.
 for reference, here is the LM339 diagram:

I did one last thing to Corvette, maybe this is what fixed it?

Shiny new glass channel!  Yes, that is what fixed the switch matrix!